Saturday, April 7, 2012

Fix No Service On iPhone 4, iPhone 3GS On iOS 5.1

This post is about to fix No Service on iPhone 4, iPhone 3Gs after updated to iOS 5.1. The culprit of the No Service error is due to Ultrasn0w you have installed to unlock your jailbroken iPhone 4 or 3Gs, the error appears because the Ultrasn0w is not compatible with iOS 5.1, at least currently.

The iPhone dev team has not update their unlocking utility to be compatible with iOS 5.1 therefore you get the No Service error. But I believe those nerds in iPhone dev team will be updating their toy. Before the update comes to public release, there is a temporary solution for the problem. In this post will help you fix No Service on your jailbroken iOS device on iOS 5.1.

First thing first, this guide can be used to the following basebands:

iPhone 4
  • 1.59.00

iPhone 3GS
  • 6.15.00
  • 5.13.04
  • 5.12.01
  • 5.11.07
  • 4.26.08

You don't know what your baseband is? Then navigate to Settings > General > About > Modem Firmware.

How to fix No Service Error On iPhone 4, iPhone 3GS on iOS 5.1 with Ultrasn0w Fixer for 5.1

Step 1: Launch Cydia on your iPhone 4 or 3GS, then navigate to this path: Manage > Sources > Edit to Add the url source below: (And click Add Source)

Step 2: Once it's added, then search and install Ultrasn0w Fixer for 5.1.

Ultrasn0w fixer for 5.1

Step 3: Now restart your device, then insert your sim card. Then boot tethered your jailbroken iPhone 4 or 3Gs again or else you will receive the Apple Logo and stuck with it, as we know the only available method to jailbreak iOS 5.1 is tethered jailbreak.

Congratulation you have get rid of the no service error on your jailbroken iPhone 4, 3Gs running on iOS 5.1!


Bro You Rock. Thank you I hope I can return the favor one day . BALA

Still No Service error. This didn't work for me.

Still got the no service error after doing the above. Any other suggestions?

this "no service" is happened everywhere,
including myself, on iPhone 4S. First 3 weeks was fine, suddenly "no service" issue came to my iPhone

Does not work on my 3gs baseband 6.15, No service remains.

Thanks works for my 3GS IOS 5.1(9B176)

I have a 3gs with an old bootrom and firmware 4.26.08. I used sn0wbreeze 2.9.3 to install ios 5.1 untethered, and added ultrasn0w 1.2.5. I had "no service" with my t-mobile SIM card until I used Ultrasn0w fixer for 5.1 version 1.0.

Nope :(

Iphone 4 with baseband 4.12.01 on IOS 5.1 (9B176)

Seeing that No Service status is like getting stabbed in the heart.

I guess NO hope for me!

my 3gs (5.1, modem 6.15) is fixed using your method. thanks a lot

I found SAM and SAMprefs fixed problem enabling default sim.

Thanks a lot. Finally fixed it with your help.

What about iPhone 4G with this baseband


It worked but it won't give me signal, just shows _ _ _ _ O2 - UK, can you help with that?

tried it on my iphone 4G and it worked perfect cheers mate

No service still. My BB is 05.16.05

Sorry it's not work for me.........

Hi all..
i have the following imei: 012534007777984
with ios 5.0.1
& firmware 4.11.08
can i now if it carrier lucked?
there is always no service
please help me :(

I'm on Vodafone an my 3GS only keeps a signal when 3G is disabled.

omg guys I solve it
I have 3gs ,ios 5.1.1,baseband 06.15.00
all what I did I opend cydia and search for(ultrasn0w) and installed it . not Ultrasn0w Fixer maybe it will help to

Post a Comment